Популярные вопросы по тегу RUBYGEMS

Эквивалент npm или rubygems в Python

... 5 было бы использовать с python. Я хочу перечислить 4 зависимости проекта в файле. ...

find_spec_for_exe ': не удается найти сборщик драгоценных камней (> = 0.a) (Gem :: GemNotFoundException)

... in_path' from /Users/myusername/.rvm/gems/ruby-2.3.5/bin/bundle:23:in `<main>' from /Users/myusername/.rvm/gems/ruby-2.3.5/bin/ruby_executable_hooks:15:in `eval' from /Users/myusername/.rvm/gems/ruby-2.3.5/bin/ruby_executable_hooks:15:in `<MacBooMacBook-MacBook-MacBook-Pro-MacBook-PrMacBook-MacBooMacBMaMacBMaMaMaMaMaMaMaMaMacBMaMaMaMacBMa Кроме того, при доступе к папке, в к ...

Невозможно установить стручки какао

... cal/Cellar/ruby/2.7.1_2/include/ruby-2.7.0/x86_64-darwin19 -I/usr/local/Cellar/ruby/2.7.1_2/include/ruby-2.7.0/ruby/backward -I/usr/local/Cellar/ruby/2.7.1_2/include/ruby-2.7.0 -I. -I/usr/local/opt/libyaml/include -I/usr/local/opt/openssl@1.1/include -I/usr/local/opt/readline/include -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -D_DARWIN_UNLIMITED_SELECT -D_REENTRANT -O3 -ggdb3 -Wall -Wextra -Wdeprecat ...

Ошибка при установке mini_racer (0.2.0)

... VALUE*, register long); ^~~~~~~~~ 2 warnings generated. linking shared-object mini_racer_extension.bundle clang: warning: libstdc++ is deprecated; move to libc++ [-Wdeprecated] ld: library not found for -lstdc++ clang: error: linker command failed with exit code 1 (use -v to see invocation) make: *** [mini_racer_extens ...

У вас нет прав на запись в каталог /Library/Ruby/Gems/2.3.0. (пользователь Mac)

... о проекта. Затем 10 запустите bundle install. Чтобы запустить один файл спецификации, выполните 9 такую ​​команду: bundle exec rspec spec/00_hello_spec.rb. Чтобы запустить сразу 8 все спецификации, запустите bundle exec rspec. Итак, я набрал 7 gem install bundler в Терминале и получ ...

Команда установки сборщика OSX не найдена

... в Запустите bundle install, чтобы 4 установить отсутствующие драгоценные камни. Когда 3 я пытаюсь запустить установку паке ...

Ошибка при запуске "bundle install" на Mac - не удается установить therubyracer

... namic' компиляция 54 v8_debug.cpp clang: warning: аргумент 53 не используется во время компиляции: '-rdynamic' компиляция 52 v8_exception.cpp clang: warning: аргумент 51 не используется во время компиляции: '-rdynamic' v8_exception.c ...

Не удалось найти гем 'pg (= 0.12.4) ruby' ни в одном из источников драгоценных камней, перечисленных в вашем Gemfile или доступных на этом компьютере

... comment above # the declaration explaining why the gem was added. # # Root # gemspec path: 'ui' gemspec path: 'engine' gemspec name: 'metasploit-framework-full', path: 'msf3' Metasploit::Pro::Metamodules.gemspecs(self) # We purchase and use RailsLTS which is slipstreamed into our build process. # RailsLTS requires this publically available gem. # Please note, installing this gem on its own does not install RailsLTS. gem ...

При выполнении драгоценного камня неизвестная команда

... Unknown command tilt Когда 4 я запускаю gem list, в списке появляются и tilt, и 3 mysql, поэтому они установлены. Фактически, я 2 получаю эту ошибку с каждым элемент ...

Ошибка установки mimemagic: «Не удалось найти базу данных типа MIME в следующих местах ...» в Windows

... mimemagic-0.3.10 rake aborted! Could not find MIME type database in the following locations: ["/usr/local/share/mime/packages/freedesktop.org.xml", "/opt/homebrew/share/mime/packages/freedesktop.org.xml", " ...

Как мне указать локальные файлы .gem в моем Gemfile?

... гу ли я сказать 2 Bundler использовать их? Или мне нужно у ...

Ошибка установки Ruby gem mysql2

... ient... no checking for main() in -lz... yes checking for mysql_query() in -lmysqlclient... no checking for main() in -lsocket... no checking for mysql_query() in -lmysqlclient... no checking for main() in -lnsl... no checking for mysql_query() in -lmysqlclient... no checking for main() in -lmygcc... no checking for mysql_query() in -lmysqlcli ...

Как установить гем из исходников GitHub?

... да GitHub. Как мне это сде ...

LoadError: невозможно загрузить такой файл - rspec / core / rake_task

... ;top (required)>' /Users/allenlin/.rbenv/versions/2.2.2/lib/ruby/2.2.0/rake/rake_module.rb:28:in `load' /Users/allenlin/.rbenv/versions/2.2.2/lib/ruby/2.2.0/rake/rake_module.rb:28:in `load_rakefile' /Users/allenlin/.rbenv/versions/2.2.2/lib/ruby/2.2.0/rake/application.rb:689:in `raw_load_rake ...

ОШИБКА: не удалось создать собственное расширение gem - ошибка при установке mysql2.

... staller::ExtensionBuildError: ERROR: Failed to build gem native extension. ... Make sure that `gem install mysql2 -v '0.3.11'` succeeds before bundling. Когда я б ...

Сбой установки пакета с ошибкой проверки сертификата SSL

... em) An error occured while installing multi_json (1.3.2), and Bundler cannot continue. Make sure that `gem install multi_json -v '1.3.2'` succeeds before bundling. Когда 5 я пытаюсь установить гем вручную (с помощью 4 gem install multi_json -v '1.3.2'), он работает. Та же проблема возникает 3 с несколькими другими драго ...

Gem :: Ext :: BuildError: ОШИБКА: не удалось создать собственное расширение gem для рельсов версии 4.2.6.

... ension. current directory: /var/lib/gems/2.3.0/gems/json-1.8.6/ext/json/ext/generator/usr/bin/ruby2.3 -r ./siteconf20170704-11395-12tpg5u.rb extconf.rb mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h extconf failed, exit code 1 Gem files will remain installed in /var/lib/gems/2.3.0/gems/jso ...

PG :: InvalidParameterValue: ERROR: недопустимое значение для параметра client_min_messages: "panic

... :128:in `block in execute' /Users/galaxy/.rvm/gems/ruby-2.1.2@folderName/gems/activerecord-4.1.6/lib/active_record/connection_adapters/abstract_adapter.rb:373:in `block in log' /Users/galaxy/.rvm/gems/ruby-2.1.2@folderName/gems/activesuppo ...

В чем разница между ~> и> = при указании rubygem в Gemfile?

... ольше 3 или равен, но что означает обозначение (~>)? Они 2 оба одинаковые или имеют какое-либо существенное 1 р ...

Вы уже активировали X, но вашему Gemfile требуется Y

... Вы уже 5 активировали рейк 0.9.2, но для вашего Gemfile 4 требуется рейк 0.8.7. Рассмотрите возможность 3 использования пак ...

Как вы понижаете рейтинг Rubygems?

... манда для понижения 1 версии Rubygem ...

Стойка: команда не найдена

... u 4 11.04, но я получаю сообщение об ошибке: -bash: rackup: command not found. Я 3 установил и рельсы, и стойки с рубиновыми 2 драго ...

Не удается найти клиентскую библиотеку PostgreSQL (libpq)

... --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby --with-pg --without-pg --with-pg-dir --without-pg-dir ...

Невозможно установить pg gem

... /bin/ruby --with-pg --without-pg --with-pg-dir --without-pg-dir --with-pg-include --without-pg-include=${pg-dir}/include --with-pg-lib --without-pg-lib=${pg-dir}/lib --with-pg-config --without-pg-conf ...

Невозможно потребовать openssl, установить OpenSSL и перестроить ruby ​​(предпочтительно) или использовать источники, отличные от HTTPS.

... and rebuild ruby (preferred) or use non-HTTPS sources $gem source -l https://ruby.taobao.org $which openssl /usr/local/bin/openssl Приветствую 1 ваши предложения ...

Как узнать, где установлены гем-файлы

... торые 5 установлены с помощью gem list, но он не показывает 4 мне, где установлены драгоценные камни. Как 3 я могу узнать, ...

Ошибка при загрузке плагина RubyGems , openssl.bundle (LoadError)

... global/gems/rubygems-bundler-1.2.2/lib/rubygems_plugin.rb": dlopen(/Users/chiang/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/x86_64-darwin12.3.0/openssl.bundle, 9): Library not loaded: /opt/local/lib/libssl.1.0.0.dylib Referenced from: /Users/chiang/.rvm/rubies/ruby-2.0.0-p247/li ...

Тайм-аут при установке рубиновых драгоценных камней

... gem 'nokogiri' (>= 0), here is why: Unable to download data from https://rubygems.org/ - Errno::ETIMEDOUT: Operation timed out - connect(2) (https://api.rubygems.org/latest_specs.4.8.gz) ERROR: Possible alternatives: nokogiri И a2z: ERROR: Could not find a valid gem 'a2z' (>= 0), here is why: Unable to download data from https://rubygems.org/ - Errno::ETIME ...

Обновите только один драгоценный камень с помощью бандлера

... к для управления зависимостями 7 в моем приложении rails, и у меня есть гем, размещенный 6 в репозитории git, включенный следующим 5 образом: gem 'gem-name', :git =&g ...

Ошибка версии ruby ​​при нажатии на героку

... ks/turbolinks gem 'turbolinks', '~> 5' # Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder gem 'jbuilder', '~> 2.5' gem 'bootsnap', '>= 1.1.0', require: false gem 'bootstrap', '>=4.0' group :development, :test do # Call 'byebug' anywhere in the code to stop execution and get a debugger console gem 'byebug', platforms: [:m ...

Команда Gem не найдена

... ежать gem install something.gem Я 4 получаю сообщение об ошибке: команда не 3 найдена. bash: gem: command not found Я установил гем, есть ли причина, по 2 которой он говорит, что не мож ...

Как сделать определенную версию гема по умолчанию?

... .0.2, 1.8.6) Здесь 6 по умолчанию установлена ​​последняя версия; однако 5 мне нужно установить json 1.8.6 по умолчанию. Ес ...

Rails: установка PG gem в OS X - не удалось создать собственное расширение

... 20 установке о том, чтобы указать мой gem install 19 в конфигурации для pg, завершается сбоем 18 со следующим сообщением об ошибке (с которым 17 сталкивались многие другие на этом форуме): Failed to build native extensions... Results logged to /Users/melanie/.rvm/gems/ruby-1.9.3-p448/gems/pg-0.17.0/ext/gem_make.out Я 16 не знаю, как найти этот файл журнала или 15 получить к нему доступ для поиска дополнительных 14 подсказок. Я также получаю ...

Предупреждение о RVM! PATH настроен неправильно

... TH размещать rvm на первом 7 месте? Мне, должно быть, не хватает какого-то 6 тривиального решения. Дополнительные примечания: $rvm --debug get head не 5 выводит никаких примечаний по установке 4 по этому поводу, за исключением предупреждения, опубликованного 3 выше. Обновление: вызов rvm system ус ...

Не могу загрузить такой файл - бандлер / настройка (LoadError)

... n `require' /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/lib/phusion_passenger/loader_shared_helpers.rb:212:in `run_load_path_setup_code' /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/helper-scripts/rack-preloader.rb:96:in `preload_app' /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/helper-scripts/rack-preloader.rb:150:in `<module:App>' /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/helper-scripts/rack-preloader.rb:29:in `&lt ...

ОШИБКА: При выполнении драгоценного камня ... (Errno :: EPERM) Операция не разрешена

... чужин не осталось. Проблема 6 возникла, когда я пытался запустить установку 5 разных драгоценных камней ... например: > sudo gem install compass После 4 выполнения я получаю сообщение об ошибке: > ERROR: While executing gem ... (Errno::EPERM) Op ...

Как отображать сообщения об ошибках проверки формы Ruby on Rails по одному?

... е, позволяет мне отображать по одной 7 ошибке из каждого поля за раз. Это не совсем 6 то, чем я хочу заниматься. Я хочу отображать 5 по одному сообщению об ошибке за раз. Например, «имя 4 не может быть пустым», то после устранения 3 этой ошибки должна отображаться следующая 2 ошибка в массиве ошибок. Это должно продолжаться 1 до тех пор, пока все ошибки не будут устранены. &l ...

Нерешенные спецификации во время Gem :: Specification.reset:

... ffi (>= 0.5.0) WARN: Clearing out unresolved specs. Please report a bug if this causes problems. Что 2 это значит и как это исправить? Сод ...

Ошибка Rails при установке mysql2 (mysql2-0.3.20)

... mini_portile2 (~> 2.0.0.rc2) oauth2 (1.3.1) faraday (>= 0.8, < 0.12) jwt (~> 1.0) multi_json (~> 1.3) multi_xml (~> 0.5) rack (>= 1.2, < 3) omniauth (1.6.1) hashie (>= 3.4.6, < 3.6.0) rack (>= 1.6.2, < 3) omniauth-facebook (4.0.0) ...

Как "gem установить nokogiri - --use-system-libraries" через Gemfile

... --use-system-libraries Но как это можно сделать 1 через Gemf ...

Компилятору не удалось создать исполняемый файл. (Ошибка выполнения)

... mf.rb:254:in `open' from /Users/mgriffel/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/mkmf.rb:284:in `block in postpone' from /Users/mgriffel/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/mkmf.rb:254:in `open' from /Users/mgriffel/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/mkmf.rb:280:in `postpone' from /Users/mgriffel/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/mkmf.rb:789:in `checking_ ...

Источник git еще не проверен при запуске Docker

... Когда 3 я запускаю bundle install из Dockerfile, он работает с таким сообщением: ... Installing sinatra 1.4.6 Installing listen 3.1.5 (was 3.0.6) Using rerun 0.11.0 from git://github.com/alexch/rerun.git (at master@3e4c486) Bundle complete! 6 Gemfile dependencies, 1 ...

Гем mysql2 в списке драгоценных камней, но получение проекта не может найти драгоценный камень

... rails', '~> 3.2.3' gem 'coffee-rails', '~> 3.2.1' # See https://github.com/sstephenson/execjs#readme for more supported runtimes # gem 'therubyracer', :platform => :ruby gem 'uglifier', '>= 1.0.3' end gem 'j ...

Не удается запустить установку sudo pod после обновления до cocoapods 0.32.1 с ошибкой «Вы не можете запустить CocoaPods от имени пользователя root. (CLAide :: Help)

... ить установку pod со старыми 7 cocoapods, он попросил меня обновить до 6 последней версии cocoapods, то есть 0.32.1. После 5 обновления с помощью cocoapods gem я не 4 могу выполнить установку sudo pod в моем 3 проекте Xcode. Это дает мне следующую ошибку. ± sudo pod install ...

Как я могу указать локальный гем в моем Gemfile?

... , чтобы Bundler загрузил локальный 3 драгоценный камень. Есть ли для этого возможность? Или 2 мне ...

Не удается связать установку puma 4.3.5 или gem puma с ruby-2.6.6 на macos-10.15.6

... : function 'raise_error' could be declared with attribute 'noreturn' [-Wmissing-noreturn] void raise_error(SSL* ssl, int result) { ^ 2 warnings generated. compiling puma_http11.c puma_http11.c:203:22: error: implicitly declaring library function 'isspace' with type 'int (int)' [-Werror,-Wimplicit-function-declaration] while (vlen > 0 && isspace(value[vlen - 1])) vlen--; ^ ...

Установка gem libv8 на OS X 10.9+

... rvm/gems/ruby-1.9.3-p125@proj-rails3-ruby19/gems/libv8-3.16.14.3/vendor/v8/out/x64.release/obj.target/preparser_lib/src/preparser-api.o CXX(target) /Users/me/.rvm/gems/ruby-1.9.3-p125@proj-rails3-ruby19/gems/libv8-3.16.14.3/vendor/v8/out/x64.release/obj.target/preparser_lib/src/scanner.o CXX(target) /Users/me/.rvm/gems/ruby-1.9.3-p125@proj-rails3-r ...

Операция запрещена - / usr / bin / update_rubygems

... rubygems-update ERROR: While executing gem ... (Errno::EPERM) Operation not permitted - /usr/bin/update_ ...

gem install pg --with-pg-config работает, связка не работает

... -lib --without-pg-lib=${pg-dir}/lib --with-pg-config --without-pg-config --with-pg_config --without-pg_config Gem files will remain installed in /var/www/simpletrac/vendor/cache/ruby/1.9.1/gems/pg- 0.12.0 for inspection. Results logged to /var/www/simpletrac/vendor/cache/ruby/1.9.1/gems/pg-0.12.0/ext/gem_make.out An error occured while installing pg (0.12.0), and ...

Я использую rbenv, так почему в моей системе два пути к Gem? (OS X Lion)

... ь 6 впечатление, что двоичные файлы управляются 5 как shims в соответствующем каталоге рубиновой 4 версии. Вот что показывает моя система, когда 3 я запускаю среду gem (я исключаю нерелевантные 2 части): - GEM PATHS: - /Volumes/Data/nathan/.rbenv/versions/1.9.3-p194/lib/ruby/gems/ ...