Популярные вопросы по тегу DEPENDENCIES

Визуализация зависимостей функций R

... хотят 16 визуализировать зависимости пакетов, но 15 меня особенно интересует визуализация функций 14 внутри пакета и их зависимостей друг от 13 друга. Существуют такие инструменты, как 12 miniCRAN для графического отображения зависимостей 11 пакетов, но есть ли что-нибудь доступное 10 для графического отображения зависимостей 9 функций внутри пакета? Например, ...

npm связывает несколько локальных (взаимозависимых) модулей

... 12 они частные репозитории git. A зависит от 11 B зависит от C. Клонирование Git A и выполнение 10 npm install работает как шарм. Но при кодировании модуля 9 A я хочу работать и с B (и C). Последние два 8 тоже клонированы git. И npm link ../pathto/B работает хорошо. И 7 поскольку B зависит от C, npm link позаботился об 6 «установке» C в B/node_modules/C. Это статический клон файла, который 5 используется B. Таким образом, при выполнен ...

Maven: добавить зависимость к банке по относительному пути

... имости. Но 9 я не хочу добавлять его в репозиторий. Причина 8 в том, что я хочу, чтобы мои обычные команды 7 maven, такие как mvn compile и т. Д., Работали из коробки. (Не 6 требуя от разработчиков, чтобы они сами 5 добавили его в какой-нибудь ...

Форвардное объявление и циклическая зависимость

... #include возникает проблема 8 циклических зависимостей. Поэтому, чтобы 7 этого избежать, я попытался переслать объявление 6 уровня в Entity.h: class Level { }; Однако, поскольку Entity 5 требуется доступ к метода ...

Maven: не удалось прочитать дескриптор артефакта.

... кто-нибудь сможет помочь 14 мне с проблемой, с которой я борюсь. Когда 13 я пытаюсь создать свой проект из терминала, я 12 получаю следующую ошибку: Failed to read artifact descriptor for com.morrislgn.merchandising.common:test-data-utils:jar:0.3b-SNAPSHOT: Could not find artifact com.morrislgn.merchandising:merchandising:pom:0.3b-SNAPSHOT jar common.test-data-utils создается 11 отдельным проектом и ...

Сбой Gradle мог быть вызван несовместимостью AndroidX в этом приложении Flutter.

... ) } dependencies { classpath 'com.android.tools.build:gradle:3.3.2' } } allprojects { repositories { google() jcenter() } } rootProject.buildDir = '../build' subprojects { project.buildDir = "${rootProject.buildDir}/${ ...

Произошла внутренняя ошибка во время: «Обновление зависимостей Maven.

... Dependencies". Lorg/codehaus/plexus/archiver/jar/JarArchiver; Я использую maven версии 6 3.0.4, и я пытался обновить JarArchiver 5 толь ...

Самый быстрый способ добавить Carthage в Xcode Project

... висимости 2 в проект Xcode с помощью Carthage. ...

Следует ли вносить изменения в файл package.json в репозиторий?

... выполнив 5 эту команду: npm install и, соответственно, их 4 package.JSON тоже будет обновлен. ИЛИ эти 3 файлы фактически говорят, какие новые зависимости 2 и их нужно отправить также. Было бы здоро ...

Пакеты NuGet в Unity

... еты NuGet 15 внутри Unity. Я добился того, что Unity 14 находит загруженные библиотеки DLL в соответствии 13 с этой статьей (https://www.what-could-possibly-go-wrong.com/unity-and-nuget/). Файл nuget.config можно 12 настроить для загрузки пакетов в папку Plugins 11 внутри папки Assets. Проблема в том, что 10 N ...

Должен ли я закреплять свои версии зависимостей Python?

... у это единственный 17 способ гарантировать, что ваш выпуск работает 16 так, как он работал, когда вы его разрабатывали, и 15 предотвратить критическое изменение в зависимость 14 наносит ущерб вашей библиотеке. Каким-то 13 образом я выбрал гибридное решение, в котором 12 я предполагал, что мои зависимости используют 11 semantic versioning и закрепил только основной номер версии 10 (скажем, somelib >= 2.3.0, < 3), за и ...

Невозможно использовать машинописный текст с выставкой — «Похоже, вы пытаетесь использовать TypeScript, но у вас не установлены необходимые зависимости».

... sing TypeScript, please remove the TypeScript files from your project and delete the tsconfig.json. error Command failed with exit code 1. После 5 выполнения инструкций и выполнения команды 4 yarn add .... я продолжаю видеть одно и то же сообщение 3 об ошибке. Я безуспешно пытался удалить папку 2 node_modules и файл package-lock.json. Я также пытался выполнить ответ 1 this. Люба ...

Не удалось найти метаданные в локальном

... 2</version> <configuration> <source>1.6</source> <target>1.6</target> </configuration> </plugin> </plugins> </build> <repositories> <repository> <id>local-artifactory</id> ...

Как заставить maven брать ресурсы из / src / test / resources вместо / src / main / resources для зависимого проекта?

... <artifactId>maven-failsafe-plugin</artifactId> <version>2.6</version> <executions> <execution> <goals> <goal>integration-test</goal> <goal>v ...

CMake graphviz автоматически сгенерирован

... а зависимостей 6 проекта CMake с помощью интерфейса командной 5 строки: cmake --graphviz=[file] Но есть ли способ создать его автоматически, просто 4 ...

Xcode: запуск скрипта перед каждой сборкой, который напрямую изменяет исходный код

... качестве цели make и файлы конфигурации 18 в качестве целевых источников: SRC = $(shell find ../config -iname "*.txt") STAMP = $(PROJECT_TEMP_DIR)/$(CONFIGURATION)$(EFFECTIVE_PLATFORM_NAME).stamp $(STAMP): $(SRC) python inject.py touch $(STAMP) Я добавил 17 этот Makefile как «Фазу сборки сценария 16 выполнения» поверх стека фаз сборки для 15 цели проекта. Что произошло: Фаза сборки скрипта была запущена 14 перед компи ...

Зависимость дизайна от android x

... idx.design:design:1.0.2' Компактная версия 2 приложения: implementation 'androidx.appcompat:appcompat:1.0.2' У меня такая ошибка - ОШ ...

Ленивая инициализация зависимостей, введенных в конструктор

... rface IOrganizer { void Method1(); void Method2(); void Method3(); } public class Organizer : IOrganizer { private IService1 _service1; private IService2 _service2; public Organizer(Iservice1 service1, IService2 service2) { _service1 = service1; _service2 = service2; } public void Method1() { /*makes use of _service1 and _service2 both to serve th ...

Как удалить столбец с зависимостями объектов в SQL Server 2008?

... eKontakt 10 имеет тип udKeyword (nvarchar (50)) со значением 9 по умолчанию dbo.defEmptyString. Редактировать 2: решено Теперь я могу решить проблему. Извините, я 8 не скопировал полное сообщение об ошибке, которое 7 было: Сообщение 5074, уровень 16, состояние 1, строка 1 Объект defEmptyS ...

Как правильно включить зависимости в R-пакет?

... на R и немного отчаялся из-за того, как 25 медленно я продвигаюсь. Довольно быстро 24 удалось собрать пакет без зависимостей, все 23 работает нормально. Из-за рекомендаций в 22 нескольких сообщениях я использую R Studio, devtools 21 и Roxygen2 (находящийся в Windows). С зависимостями 20 у меня возникают проблемы при ПРОВЕРКЕ (например, с 19 помощью devtools :: check()): проверка зависимостей 18 в коде R ... ...

Как разрешить конфликтующие зависимости модуля go, когда модуль верхнего уровня и один из его подмодулей отдельно импортируются как отдельные версии?

... ithub.com/foo/bar" ) func MyFunc() {...bar.NewBar()...} Когда я пытаюсь 11 запустить тест MyFunc (который существует в другом 10 месте), я получаю сообщение об ошибке unknown import path...ambiguous import.... например go test github.com/test-org/test-repo/test-package -test. ...

Maven проверяет наличие обновленных зависимостей в репозитории

... м проверять, есть ли в репозитории более 6 новые версии зависимостей? Допустим, вы используете 5 зависимость X с версией 1.2. Теперь выпущен ...

Бесплатный граф зависимостей проекта Visual Studio C#

... кта 6 Visual Studio 2019 на графике зависимостей. Я 5 видел некоторые доступные инструменты, но 4 они требуют, чтобы вы запла ...

Обновить зависимости Composer до последней версии, несмотря на статические номера версий?

... вал статические номера версий? Я 2 хотел бы сохранить статические номера ...

Как мне справиться с установкой одноранговых зависимостей в Angular CLI?

... equires a peer of @angular/common@^4.0.3 but none is installed. You must install peer dependencies yourself. npm WARN @ng-bootstrap/ng-bootstrap@1.0.0-beta.6 requires a peer of @angular/forms@^4.0.3 but none is installed. You must install peer dependencies yourself. npm WARN @schematics/angular@0.1.17 requires a peer of @angular- devkit/core@0.0.29 but none is installed. You must install peer dependencies yourse ...

Как посчитать количество установленных пакетов, включая зависимости

... получить количество 7 установленных пакетов npm, как глобальных, так 6 и локальных для приложения? Например, после 5 запуска create-react-app [1] я получаю заполненные экранами 4 пакеты и зависимости, установленные, когда 3 я ввожу команду npm ls. Как найти количество (&quo ...

Автоматическая установка npm --legacy-peer-deps для одной зависимости

... gacy-peer-deps, и все, похоже, отлично 14 работает с моей версией реакции react@17.0.2. Я не хотел 13 бы запускать npm i --force и npm i --legacy-peer-deps каждый раз, когда мне нужно 12 установить зависимости, поэтому я искал 11 способ автоматически делать это только для 10 mathjax-react и mathjax-full всякий раз, когда я запускаю npm i. Я пробовал 9 искать в .npmrc docs и в этом reference, но не смо ...

Проверка гибернации: ошибка «Невозможно инициализировать javax.el.ExpressionFactory»

... .springframework</groupId> <artifactId>spring-context</artifactId> <version>4.3.6.RELEASE</version> <scope>runtime</scope> </dependency> <dependency> <groupId>org.springframework</groupId> ...

В чем разница между mustRunAfter и зависимым от Gradle?

... taskA или taskB, зависит от taskA, кажется, что 2 сначала запускается taskA, затем запускаетс ...

Поиск DLL, необходимых для Win exe в Linux (кросс-скомпилированный с mingw)?

... още 8 простого. Однако упаковать его необходимыми 7 DLL оказалось не так просто. На данный момент 6 решение состоит в том, чтобы запустить исполняемый 5 файл в Windows и скопировать библиотеки 4 DLL, пока он не запуститс ...

Эквивалент package.json и package-lock.json для pip

... е (упрощенного) эквивалента 6 package.json и requirements-prod.lock, который содержит вывод pip freeze и действует 5 как мой lock -file. Вдобавок я мог бы иметь 4 requirements-dev.txt для зависимостей разработки и т. Д. И т. Д. Я 3 хотел бы знать, ...

Gradle: В чем разница между зависимостями пути к классам и компиляцией?

... мер, мои зависимости 4 ниже должны быть временем компиляции или 3 путем к классам? Кроме того, должно ли это 2 быть в моих приложениях build.gradle или в конкретном 1 модуле ...

Что такое модули высокого и низкого уровня?

... ow-level modules" (in the context of Dependency inversion principle)? Но, прочитав это, я н ...

Spring-boot-starter-web зависимость hibernate-validator отсутствует на Mac

... eb</artifactId> </dependency> <dependency> <groupId>org.springframework.boot</groupId> <artifactId>spring-boot-starter-tomcat</artifactId> <scope>provided</scope> </dependency> ...

Конфигурация Wildfly с DataSource

... .servlet.jsp.jstl.tlv.PermittedTaglibsTLV\".START", "jboss.deployment.unit.\"IslamicPostsWS.war\".component.\"javax.servlet.jsp.jstl.tlv.ScriptFreeTLV\".START", "jboss.deployment.unit.\"IslamicPostsWS.war\".component.\"org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher\".START", "jboss.deployment.unit.\"IslamicPostsWS.war\".component.\"org.jboss.resteasy.plu ...

Зависимость Maven: исключить один класс

... ть зависимость: <dependency> <groupId>org.slf4j</groupId> <artifactId>slf4j-api</artifactId> <version>1.5.6</v ...

maven не может разрешить зависимость

... hreadedBuild(LifecycleStarter.java:183) at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319) at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156) at org.apache.maven.cli.MavenCl ...

Есть ли способ программно перечислить все зависимости Gradle?

... деревом зависимостей, чтобы 7 я мог распечатать ту же иерархию, но в JSON 6 вместо формата, который сейчас использует 5 gradle cli в консоли. Какие классные классы 4 мне следует использовать для этого? ИЗМЕНИТЬ Я хотел 3 бы получить (в JSON) что-то вроде этого: "dependencies" : [ { "groupId" : "com.somethi ...

Отправить вывод maven в файл

... сь проанализировать. Команда: mvn dependency:tree -Dverbose -Dincludes=commons-collections -DoutputFile=C:\Users\myname\Documents\output.txt Когда 4 я запускаю команду без параметра outputFile, я вижу 3 вывод, отправленный на консоль. Но когда 2 я испол ...

Как добавить проект Maven в качестве зависимости Gradle?

... adle, над которым 4 я работаю, и некоторый многомодульный проект 3 Maven, который я хотел бы импортировать 2 в свой проект Gradle ...

Использование g ++ с -MMD в make-файле для автоматического создания зависимостей

... в какой 13 момент создаются файлы .d? Нет даже команды, в 12 которой используется ${CXXFLAGS}. Предположительно, такие 11 команды, как ${CXX} ${CXXFLAGS} -c x.C -o x.o, будут автоматически выводиться 10 make для каждого из объектных файлов, но 9 если это команды, которые генерируют файлы 8 .d, разве мы уже не прошли точку, в которой 7 мы знаем зависимости xo, yo и zo могли бы 6 быть актуальными, если бы мы знали их только 5 путе ...

Почему реакция обычно должна быть зависимостью от продукта, а не от разработчика

... олжна быть зависимостью, а 11 не зависимостью от разработчика в большинстве 10 проектов .. Обычно src написан на es6 и 9 хранится, например, в / src или / client, и 8 когда кто-то хочет собрать проект для prod, он 7 создаст / build или / dist, где будет размещаться 6 finalize bundle.js (с использованием webpack 5 и т. Д.) . оттуд ...

Различные зависимости для разных профилей сборки

... ь разные наборы зависимостей 4 в файле maven pom.xml для разных профилей? напр. mvn -P debug mvn -P release Я 3 хотел бы подобра ...

Связывание с динамической библиотекой с зависимостями

... A.so a.o g++ -fPIC b.cpp -c -I. g++ -shared -o libB.so b.o -L. -lA Какие из приведенных ниже вариантов 19 мне следует использовать? g++ main.cpp -o main -I. -L. -lB или g++ main.cpp -o main -I. -L. -lB -lA Я не смог использовать 18 первый вариант. Компоновщик жалуется на 17 неразрешенные символы из библиотеки libA. ...

(Re) Проверка зависимостей с помощью PIP

... симости пакетов, установленных 6 с помощью pip? То есть, допустим, у нас 5 есть рабочая среда. Затем один из пакетов 4 изменяется (обновляется и т. Д.). Есть ли 3 кома ...

Ошибка зависимости в jasper-отчетах от itext

... ad artifact descriptor for com.lowagie:itext:jar:4.2.2: Could not transfer artifact com.itextpdf:itextpdf:pom:4.2.2 from/to jaspersoft (http://www.jasperforge.org/maven2): Access denied to http://www.jasperforge.org/maven2/com/itextpdf/itextpdf/4.2.2/itextpdf-4.2.2.pom. Error code 403, Forbidden -> [Help 1] ...

Как я могу связать зависимости в репозитории git?

... ории. Я не хочу дублировать их в 5 моем репо и постоянно обновлять их каждый 4 раз, когда выходит новая версия. Однако, когда 3 кто-то клонирует репо, оно ...

Как установить совместимость jvm target compileJava 'task (11) и' compileKotlin 'task (1.8) на одну и ту же версию Java в build.gradle.kts?

... nerateVersionsFileTask>("generateSources") ОШИБКА: Задача compileJava 6 (текущая цель - 11) и задача compileKotlin 5 (текущая цель - 1.8) совместимость цели 4 jvm должна быть установлена ​​на одну и 3 ту же версию Jav ...

Как указать репозиторий для зависимости в Maven

... ями метод проб и ошибок Maven 7 для загрузки зависимостей является немного 6 громоздким и медленным, поэтому мне было 5 интересно, есть ли способ установить конкретное 4 репо для некоторых заявленных зависимостей. Н ...

Вы знаете профиль Maven для mvnrepository.com?

... позитории Maven 2 по умолчанию http://repo1.maven.org/maven2/. Они 4 доступны на http://mvnrepository.com/. Но мне не удалось найти профиль 3 этого сайта для включения в мой settings.xm ...